Информатика, вопрос задал korzhova , 1 год назад

Дано четырехзначное число, составить программу подсчета количества нечетных цифр в этом числе и сообщение false(если таких цифр нет) и true (если есть).
Питон

Ответы на вопрос

Ответил isteer
0

Ответ:

number = 4222

count = 0

number = str(number)  

number = list(number)

number = map(int, number)

for i in number:

   if i % 2 != 0:

       count += 1

if count == 0:

   print(count)

   print(False)

else:

   print('всего нечетных чисел:', count)

   print(True)

number = 4222

count = 0

( c комментариями)

number = str(number)

number = list(number)

number = map(int, number)

# переводим число в список

for i in number:

   if i % 2 != 0:

       count += 1

#находим нечетное число

if count == 0:

   print(count)

   print(False)

else:

   print('всего нечетных чисел:', count)

   print(True)

# выводим его

Новые вопросы