дано целое двузначное число. Составить программу которая определяет входит ли в него цифра 4
Ответы на вопрос
Ответил alexey471408
1
На псевдокоде
Алг(a,b,fl)
Арг a,b
Рез fl
ввод(a;b) {где а-это десятки,b-еденицы}
fl:=true
Если (a=4)или(b=4) то fl:=true все
Если fl=true то вывод('есть') иначе вывод('нету')
конец
Алг(a,b,fl)
Арг a,b
Рез fl
ввод(a;b) {где а-это десятки,b-еденицы}
fl:=true
Если (a=4)или(b=4) то fl:=true все
Если fl=true то вывод('есть') иначе вывод('нету')
конец
Ответил Tlalok
2
var
a:byte;
begin
write('Введите число '); readln(a);
if (a div 10 = 4) or (a mod 10 = 4) then
writeln('В число входит цифра 4')
else
writeln('цифра 4 в число не входит');
end.
Новые вопросы
Окружающий мир,
2 года назад
Английский язык,
2 года назад
Математика,
2 года назад
Английский язык,
2 года назад