Информатика, вопрос задал nastyaderhache , 8 лет назад

Дано 3-х значное число (х). Составить программу для вычесления суммы и произведения цифр числа
Program ynp2;
var x, x1, x2, x3; p: integer;
begin
Write( ' введите трёхзначное число');
Read(x);
x1: x mod 100;
x3: x div 100;

Ответы на вопрос

Ответил Егуар007
0
Var x,x1,x2,x3:integer; Begin Write('введите число'); Readln(x); X1:=x mod 10; X2:=x div 100; X3:=(x div 10) mod 10; If (x1>x2) and (x1>x3) then Write(x1); If (x2>x1) and (x2>x3) then Write(x2); If (x3>x2) and (x3>x1) then Write(x3); Readln End.
Ответил nastyaderhache
0
Спасибо
Ответил Егуар007
0
не за что
Новые вопросы