Информатика, вопрос задал Maria73734 , 8 лет назад

Дана последовательность 5, 9, 13, 17,... Напишите программу определения числа слагаемых, сумма которых равна 324.

Ответы на вопрос

Ответил AnonimusPro
0
{формула: S=(2*a1+d*(n-1)/2)*n; 324=2*5+4n-4/2*n; 324=2n^2+3n; 2n^2+3n-324; - задача свелась к квадратному уравнению}
Program n1;
var a,b,c,d,x: real;
begin
a:=2;
b:=3;
c:=-324;
d:=b*b-4*a*c;
x:=(-b+sqrt(d))/4;
writeln(x);
end.
Новые вопросы