Информатика, вопрос задал HitchedLime , 7 лет назад

Дана последовательность: 1; 1+ ½; 1+ ½ +1/3;…; 1+1/2+… +1/n. Составить программу, вычисляющую первый член последовательности, превосходящий заданное число A.Язык:Python


Rediska873: язык?
HitchedLime: Python

Ответы на вопрос

Ответил Rediska873
1

a = float(input('Введите A: '))

sum = 1

n = 2

while sum <= a:

   sum = sum + 1/n

   n = n + 1

print(sum)

Новые вопросы