Дана площадь квадрата. Составьте программу для вычисления его стороны и периметра.
Программу хорошую и понятную составить( в Паскале), все-таки баллов не мало
Ответы на вопрос
Ответил A1dar
0
var
s, a, p: real;
begin
write('Введите площадь квадрата: ');
read(s);
a := sqrt(s); //Сторона
p := a * 4; //Периметр
writeln('Сторона квадрата = ', a : 0 : 2);
writeln('Периметр квадрата = ', p : 0 : 2);
end.
s, a, p: real;
begin
write('Введите площадь квадрата: ');
read(s);
a := sqrt(s); //Сторона
p := a * 4; //Периметр
writeln('Сторона квадрата = ', a : 0 : 2);
writeln('Периметр квадрата = ', p : 0 : 2);
end.
Ответил Аноним
0
мерси :з
Ответил Аноним
0
а что значит а:0:2
Ответил A1dar
0
0 - количество выделяемых знаков под число. В данном случае оно равно 0 и число форматируется под нужное ему число знаков. 2 - это количество знаков после запятой
Ответил Аноним
0
а обязательно вот ти две строки писать?:D которые перед end
Ответил Аноним
0
а то мы так не делали, боюсь, что заподозрят :D
Ответил Аноним
0
Var
s:real; //Могут быть и не целые числа
Begin
Write('Введите площадь квадрата ');
Readln(s);
Write('Сторона квадрата равна ',sqrt(s),', а периметр ',sqrt(s)*4); // sqrt - это квадратный корень (тобиш длина квадрата) а sqrt(s)*4 - это сторона квадрата умноженная на 4 стороны тобиш периметр
End.
s:real; //Могут быть и не целые числа
Begin
Write('Введите площадь квадрата ');
Readln(s);
Write('Сторона квадрата равна ',sqrt(s),', а периметр ',sqrt(s)*4); // sqrt - это квадратный корень (тобиш длина квадрата) а sqrt(s)*4 - это сторона квадрата умноженная на 4 стороны тобиш периметр
End.
Ответил Аноним
0
и тебе спасибо :з
Ответил Аноним
0
Жмякни кнопку спасибо
Новые вопросы
Русский язык,
2 года назад
Математика,
2 года назад
Обществознание,
9 лет назад
История,
9 лет назад