Информатика, вопрос задал drozdowdaniil229 , 2 года назад

Дан одномерный массив Y, состоящий из 15 элементов. Подсчитать сумму и произведение элементов массива, меньших 30. Написать программу решения задачи на языке программирования здесь

Ответы на вопрос

Ответил Sanya2263
1

var a: array [1..15] of integer;

i, n, s, p: integer;

begin

s:=0;

p:=1;

Read(n);

For i:= 1 to n do

Read(a[i]);

For i:=1 to n do

if a[n]<30 then begin

s:=s+a[i];

p:=p*a[i];

end;

Write(s, ' ', p);

end.


drozdowdaniil229: 'n' не является именем переменной
Sanya2263: Скопируй решение еще раз. Я кое-что изменил
drozdowdaniil229: Спасибо
Sanya2263: Работает?
Sanya2263: Введи 15, enter, и 15 единиц. Должна выйти сумма 15 и произведение 1
Ответил restIess
0

s,pr = 0,1

Y = []

for i in range(30):

   Y.append(int(input()))

for i in range(30):

   if Y[i] < 30:

       s += Y[i]

       pr *= Y[i]

print(s,pr)

Новые вопросы