Информатика, вопрос задал Ksyu99 , 9 лет назад

Дан одномерный массив натуральных чисел из 12 элементов найдите наименьшее из четных чисел, входящих в массив

Ответы на вопрос

Ответил Kbhjq1337
0
const N = 5;var a: array [1..N] of integer;k,i:integer;begink:=maxint;for i:= 1 to N do  readln (a[i]);for i:=1 to N do beginif (i mod 2 = 0) and (a[i]<k) then k:= a[i] end;writeln (k);end.
Ответил Kbhjq1337
0
const N = 5;
var a: array [1..N] of integer;
k,i:integer;
begin
k:=maxint;
for i:= 1 to N do
readln (a[i]);
for i:=1 to N do begin
if (i mod 2 = 0) and (a[i]<k) then
k:= a[i] end;
writeln (k);
end.
Ответил Ksyu99
0
maxint? это что?
Ответил Kbhjq1337
0
максимальное число в Integer
Ответил Ksyu99
0
а просто max нельзя? Это уже ошибка, да?
Ответил Kbhjq1337
0
просто макс константы в паскале нет
Новые вопросы