Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4...). Сначала задано число — количество элементов в массиве. Далее через пробел записаны чисел — элементы массива. Массив состоит из целых чисел. Необходимо вывести все элементы массива с чётными номерами. Необходимо единственное число - количество положительных элементов в массиве. C++
Ответы на вопрос
Ответ:
#include <iostream>
using namespace std;
int main() {
int n;
cin >> n;
int arr[n];
for (int i = 0; i < n; i++) {
cin >> arr[i];
}
int count = 0;
for (int i = 0; i < n; i += 2) {
if (arr[i] > 0) {
cout << arr[i] << " ";
count++;
}
}
cout << endl << count << endl;
return 0;
}
Объяснение:
Программа сначала считывает количество элементов массива 'n', создает массив 'arr' нужного размера и заполняет его в цикле. Затем в цикле с шагом 2 перебираются элементы с четными номерами и выводятся на экран, если они положительны. Считается также количество положительных элементов 'count', которое выводится после того, как все необходимые элементы уже были выведены.