Дан массив, состоящий из целых чисел. Известно, что числа упорядочены по неубыванию (то есть каждый следующий элемент не меньше предыдущего). Напишите программу, которая определит количество различных чисел в этом массиве.
Входные данные
Сначала задано число N — количество элементов в массиве (1N100). Далее через пробел записаны N чисел — элементы массива. Массив состоит из целых чисел.
Выходные данные
Необходимо вывести единственное число - количество различных чисел в массиве.
Примеры
Входные данные
5
1 1 1 1 1
Выходные данные
1
Ответы на вопрос
Ответил polka125
0
program X;
var
mas: array[1..1000000] of longint;
N,i,count:longint;
begin
count:=1;
readln(N);
for i:=1 to N do
read(mas[i]);
if N>1 then
begin
for i:=2 to N do
if mas[i]<>mas[i-1] then inc(count);
writeln(count)
end
else
writeln(1)
end.
var
mas: array[1..1000000] of longint;
N,i,count:longint;
begin
count:=1;
readln(N);
for i:=1 to N do
read(mas[i]);
if N>1 then
begin
for i:=2 to N do
if mas[i]<>mas[i-1] then inc(count);
writeln(count)
end
else
writeln(1)
end.
Новые вопросы
Геометрия,
2 года назад
Другие предметы,
2 года назад
Математика,
9 лет назад
Математика,
10 лет назад