Дан массив из тридцати элементов. Вывести индексы всех элементов, равных по значению а.
Если таких элементов нет - вывести сообщение с текстом "No solution".
Формат входных данных
На первой строке через пробел записаны целые числа Arri (|Arri|≤1000) — элементы массива.
На второй строке записано целое положительное число a.
Формат выходных данных
Строка, содержащая искомые индексы, либо знадпись "No solution", если таковых нет.
Ответы на вопрос
Ответил igor9997799
0
var
i, x: integer;
a: array[1..30]of integer;
b: boolean;
begin
b := false;
for i := 1 to 30 do read(a[i]);
readln(x);
for i := 1 to 30 do if(a[i] = x) then
begin
b := true;
write(i, ' ');
end;
if (b = false) then write('No solution');
end.
i, x: integer;
a: array[1..30]of integer;
b: boolean;
begin
b := false;
for i := 1 to 30 do read(a[i]);
readln(x);
for i := 1 to 30 do if(a[i] = x) then
begin
b := true;
write(i, ' ');
end;
if (b = false) then write('No solution');
end.
Новые вопросы
Биология,
2 года назад
Биология,
2 года назад
Математика,
9 лет назад
Геометрия,
9 лет назад
Алгебра,
9 лет назад