дан массив из семи элементов написать программу подсчитывающую
среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива
Ответы на вопрос
Ответил kolesin
0
тебе на поскале судя по всему надо, я его давно изучал синтаксис позабыл но алгоритм могу подсказать
1)
Var arr:массив(от 0 до 6);
begin
пока i<6 //ввод массива
readln(arr[i]);
конец;
writeln((i[1]+i[5])/2);//вывод среднего числа
end.
2)задача описана некорректно
3)
Var arr:массив(от 0 до 29),n:integer;
begin
пока i<30 //ввод массива
readln(arr[i]);
конец;
пока j<29
n=n+arr[j];
конец;
writeln(N/30);//вывод среднего числа
end.
1)
Var arr:массив(от 0 до 6);
begin
пока i<6 //ввод массива
readln(arr[i]);
конец;
writeln((i[1]+i[5])/2);//вывод среднего числа
end.
2)задача описана некорректно
3)
Var arr:массив(от 0 до 29),n:integer;
begin
пока i<30 //ввод массива
readln(arr[i]);
конец;
пока j<29
n=n+arr[j];
конец;
writeln(N/30);//вывод среднего числа
end.
Ответил нелькин
0
СПАСИБО!!!!
Новые вопросы
История,
2 года назад
Русский язык,
2 года назад
Литература,
10 лет назад
Математика,
10 лет назад
Математика,
10 лет назад
Химия,
10 лет назад