Информатика, вопрос задал Аноним , 9 лет назад

Дан массив из n элементов. Необходимо вывести количество элементов, которые больше своих «соседей» (следующего и предыдущего элементов).

Формат входных данных

С клавиатуры вводится натуральное число nn (n≤100n≤100). На следующей строке через пробел вводятся nn элементов массива. Все числа целые и по модулю не превосходят 100.
Формат выходных данных

В качестве ответа выведите единственное число — количество искомых элементов.
Примеры

входные данные:
6
1 2 1 3 2 4
выходные данные:
3

Ответы на вопрос

Ответил Gleb1Kosyrev
0
//Dev-C++ 5.11 (C)

#include <stdio.h>

int main(void)
 {int arr[100],n,k;
 scanf("%d",&n);
 k=0;
 for(int i=0;i<n;i++)
  scanf("%d",&arr[i]);
 for(int i=0;i<n;i++)
  if(i==0 && arr[i]>arr[i+1])k++;
  else
  if(i==n-1 && arr[i]>arr[i-1])k++;
  else
  if(arr[i]>arr[i-1] && arr[i]>arr[i+1])k++;
 printf("%d",k);
 return 0;}
Новые вопросы