Информатика, вопрос задал Suvorova199875 , 9 лет назад

Дан массив из N элементов. Найти сумму элементов с четными номерами и отдельно-с нечетными.
Написать программу.

Ответы на вопрос

Ответил ZombieLite
0
#include <stdio.h>
#include <string.h>
#include <iostream>

void main() {
    int a[100];
    int b = 0, c = 0;
    bool change = false;
    for (int i = 0; i < 100; ++i) {
        if (!change) {
            ++b;
        } else {
            ++c;
        }
        ++a[i];
        change = !change;
    }
    printf("4eTHble: %d | He 4eTHble: %d", b, c);
    getchar();
}

Новые вопросы