Дан массив из N чисел. N - четное. Написать программу, меняющую местами элементы с четными и нечетными номерами.
Плиз помогите оч надо
Ответы на вопрос
Ответил Dijas
0
Program Yolo;
Uses Crt;
Const N=16;
Var Mass: array [1..n] of integer;
Back: integer;
i: byte;
Begin
Randomize;
ClrScr;
Writeln('Исходная матрица [-15;15]: ');
For i:=1 to N do
Begin
Mass[i]:=Random(31)-15;
Write(Mass[i]:4);
End;
Writeln;
For i:=1 to N do
If i mod 2<>0 then
Begin
Back:=Mass[i];
Mass[i]:=Mass[i+1];
Mass[i+1]:=Back;
End;
Writeln('Отформотированный матрица: ');
For i:=1 to N do
Write(Mass[i]:4);
Readln;
End.
Uses Crt;
Const N=16;
Var Mass: array [1..n] of integer;
Back: integer;
i: byte;
Begin
Randomize;
ClrScr;
Writeln('Исходная матрица [-15;15]: ');
For i:=1 to N do
Begin
Mass[i]:=Random(31)-15;
Write(Mass[i]:4);
End;
Writeln;
For i:=1 to N do
If i mod 2<>0 then
Begin
Back:=Mass[i];
Mass[i]:=Mass[i+1];
Mass[i+1]:=Back;
End;
Writeln('Отформотированный матрица: ');
For i:=1 to N do
Write(Mass[i]:4);
Readln;
End.
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
Алгебра,
2 года назад
Литература,
2 года назад
Литература,
7 лет назад
Алгебра,
7 лет назад