Информатика, вопрос задал Frisbir , 7 лет назад

Дан массив из 30 элементов из интервала[-15;15].Составить программу нахождение суммы отрицательных элементов,больших -9​ Пж ответьте


huston81: какой язык?
Frisbir: паскаль
huston81: 2 мин

Ответы на вопрос

Ответил huston81
1

Ответ:

pascal

Объяснение:

var i, s: integer;

   a: array[1..30] of integer;

begin

 randomize;

 for i := 1 to 30 do

 begin

   a[i] := random(31) - 15;

   Write(a[i], ' ');

   if (a[i] > -9) and (a[i] < 0) then s := s + a[i];

 end;

 WriteLn;

 WriteLn('Сумма отрицательных элементов,больших -9, равна ', s);

end.


Frisbir: спасибо
Новые вопросы