Дан массив из 30 чисел, они могут быть от -1000 до 1000.
Напишите программу, которая найдет и выведет на экран среди этих чисел максимальное отрицательное число, не оканчивающееся на 3.
Ответы на вопрос
Ответил Fluorum2006
0
VAR
A: ARRAY [1..30] OF INTEGER;
i, max: INTEGER;
BEGIN
FOR i := 1 TO 30 DO READ (A[i]);
max := -1001;
FOR i := 1 TO 30 DO
IF (A[i]<0) AND (A[i]>max) AND (A[i] MOD 10 <>3) THEN
max := A[i];
WRITELN (max);
END.
A: ARRAY [1..30] OF INTEGER;
i, max: INTEGER;
BEGIN
FOR i := 1 TO 30 DO READ (A[i]);
max := -1001;
FOR i := 1 TO 30 DO
IF (A[i]<0) AND (A[i]>max) AND (A[i] MOD 10 <>3) THEN
max := A[i];
WRITELN (max);
END.
Новые вопросы