Дан массив из 20 целых чисел. Определите, сколько элементов этого массива имеют максимальное значение.
Ответы на вопрос
Ответ:
program average;
const n=20;
var max:integer;//макс. элемент массива
count:integer;//кол-во эл-тов массива,равные максимальному
m:array[1..n] of integer; //массив из 20 целых чисел
i:byte; //счетчик цикла
begin
count:=0; max:=0;
writeln('Введите в строку 20 чисел');
for i:=1 to n do begin
read(m[i]);//считываем в цикле 20 чисел
if (m[i]>max) then max:=m[i]; //если эл-т массива больше максимальнго, то он сам становится максимальным
end;
//перебираем массив в цикле
for i:=1 to n do
if (m[i]=max) then count:=count+1;//если элемент массива равен максимальному, то счетчик таких чисел увеличиваем на 1
//вывод на экран требуемого значения
writeln(count);
end.
Объяснение:
объяснение в комментариях к строкам кода