Дан массив из 10 чисел. Определите, сколько элементов этого массива имеют минимальное значение.
(Паскаль)
Ответы на вопрос
Ответил FlowerStorm
0
Если одномерный массив, то:
program min;
var a:array[1..10] of integer;
i,min,k:integer;
begin
writeln('Введите элементы массива');
for i:=1 to 10 do
readln(a[i]);
min:=a{1];
for i:=1 to 10 do
if a{i]<min
then min:=a{i};
for i:=1 to 10 do
if a{i]=min
then k:=k+1;
writeln('Всего элементов с минимальным значением =',k);
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Биология,
7 лет назад
ОБЖ,
7 лет назад
Алгебра,
9 лет назад