Информатика, вопрос задал sergei814 , 8 лет назад

Дан массив из 10 целых чисел в диапазоне [-10000,10000]. Определите максимальный элемент, кратный 5. Если таких элементов нет, выведите "-1".
Числа вводятся с клавиатуры. Программу выполнить в ПАСКАЛЬ.АВС

Ответы на вопрос

Ответил certer1q
0
program c;var a:array [1..10] of integer; i,k,n:integer;begin k:=-1; n:=-10001; for i:=1 to 10 do  begin   readln(a[i]);    if(a[i] mod 5 = 0) and (a[i] > n) then     n:= a[i];   end;   if n = -10001 then    writeln(k)    else     writeln(n);end.
Ответил sergei814
0
а откуда мы взяли -10001?
Ответил certer1q
0
наименьший элемент , если нет чисел , которые нам подходят программа выведет -1
Ответил sergei814
0
спасибо
Ответил Аноним
0
Текст, если не отформатируете, или модераторы все равно заставят, или удалят ответ.
Ответил Аноним
0
PascalABC.NET 3.3.5, сборка 1659 от 09.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadSeqInteger(10).Where(t->(t mod 5=0)).ToArray;
  if a.Count=0 then Writeln(-1) else Writeln(a.Max)
end.
Приложения:
Новые вопросы