Информатика, вопрос задал zakharkst , 2 года назад

Дан массив чисел A. Нам необходимо определить текущую сумму элементов массива ArraySum [i] = sum (A[0]… A[i]). Верните массив с текущей суммой чисел. Текущая сумма получается следующим образом: Массив A состоит из элементов 1,2,3,4. Результат суммирования А = 1,3,6,10. То есть 1, 1+2 (3), 1+2+3 (6), 1+2+3+4 (10). Входные данные В единственной строке входного файла INPUT записан массив А из целых чисел 1 <=Длина массива <= 1000. Элементы массива -10^6 <= А[i] <= 10^6. Выходные данные В единственную строку выходного файла OUTPUT нужно вывести массив А удовлетворяющий условию.

Приложения:

Ответы на вопрос

Ответил bondarchuknana21
4

Ответ:

N = input().split(',')

arr = []

arr2 = []

for i in N:

   i = int(i)

   n = sum(arr2) + i

   arr2.append(i)

   arr.append(n)

print(arr)

Объяснение:

Новые вопросы