Дан массив целых чисел А(25).
Составить программу для вычисления суммы
элементов массива, которые
не меньше 10.
Ответы на вопрос
Ответил Аноним
0
PascalABC.NET 3.4.2, сборка 1861 от 09.11.2018
Внимание! Если программа не работает, обновите версию!
begin
var a := ArrRandom(25, -15, 50);
a.Println;
a.Where(t -> t >= 10).Sum.Println
end.
Пример
-13 27 20 48 17 33 -6 36 12 48 -13 1 45 12 31 7 45 35 42 3 26 -10 48 27 34
586
Ответил pryhodzichdavid
0
но чат же закрыли
Ответил pryhodzichdavid
0
чтобы через переписки не делились ответами
Ответил pryhodzichdavid
0
тоесть публиковали вопрос и его решали
Ответил Аноним
0
Доступен, если Вы дали от 1000 решений. Или, если кто-то смог написать Вам.
Ответил pryhodzichdavid
0
жаль но у меня только 261 решение
Ответил pryhodzichdavid
0
var a:array[1..25] of integer;
i,z:integer;
begin
for i:=1 to 25 do
begin
a[i]:=random(50);
write(a[i],' ');
if (a[i]>=10) then z:=z+a[i];
end;
writeln;
write(z);
end.
Новые вопросы