Информатика, вопрос задал Rasta13 , 10 лет назад

Дан массив А, состоящий из 6 элементов. Вывести элементы массива. Изменить порядок следования элементов массива на обратный, вывести инвертированный массив.

 

Помогите, пожалуйста, составить программу в паскале!!!

 

Вот, например, я начала.

 

Program z10;
VAR
p, i: Integer;
x: Array [1..6] of integer;
Begin
For i:=1 to 6 Do
begin
p:=a[i];

А как дальше поменять местами остальные элементы??

Ответы на вопрос

Ответил kage1998
0
1)
просто выводим элементы наооборот
program gt;
var a:array[1..6]of longint;
n,i:integer;
begin
read(n);
for i:=1 to n do
begin
read(a[i]);
end;
for i:=6 downto 1 do
begin
write(a[i],' ');
end;
end.
2)
добавляем дополнительный массив b
program gt;
var a,b:array[1..6]of longint;
n,k,i:integer;
begin
read(n);
k:=7;
for i:=1 to n do
begin
read(a[i]);
k:=k-1;
b[k]:=a[i];
end;
for i:=1 to 6 do
begin
write(b[i],' ');
end;
end.
3)
Изменяем элементы массива без дополнительных элементов
Program z10;
VAR 
p, i: Integer; 
x: Array [1..6] of integer;
Begin
For i:=1 to 3 Do 
begin
p:=a[i];
a[i]:=a[6-i+1];
a[6-i+1]:=p;
end;
for i:=1 to 6 do
begin
write(a[i],' ');
end;
end.
Ответил kage1998
0
Program z10;
VAR
x: Array [1..6] of integer;
i:integer;
Begin
Randomize;
For i:=1 to 6 do
begin
x[i]:=random(99);
write('x[',i,']=', x[i],' ');
end;
writeln;
For i:=6 downto 1 do
begin
write('x[',6-i+1,']=', x[i],' ');
end;
end.
Ответил Rasta13
0
спасибо за помощь!
Ответил kage1998
0
ну тогда удачи!
Новые вопросы