Информатика, вопрос задал Аноним , 9 лет назад

Дан массив a из n

целых чисел. Требуется вывести только неотрицательные числа.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai
(∣∣ai∣∣≤103)

— элементы массива.

Формат выходных данных
Требуется в одной строке через пробел вывести все неотрицательные числа в том же порядке, в каком они расположены во входном файле.

Ответы на вопрос

Ответил igor9997799
0
var
  i, n: integer;
  a: array[1..1000]of integer;
 begin
  readln(n);
  for i := 1 to n do read(a[i]);
  writeln;
  for i := 1 to n do if (a[i] >= 0) then write(a[i], ' ');
end.
Новые вопросы