Информатика, вопрос задал Аноним , 9 лет назад

Дан массив a из n

целых чисел. Требуется посчитать количество положительных элементов и количество отрицательных элементов.

Формат входных данных
На первой строке входного файла записано натуральное число n (n≤100) — число элементов в массиве.

На следующей строке через пробел записаны целые числа ai
(|ai|≤1000) — элементы массива a

.

Формат выходных данных
Требуется через пробел вывести два числа — количество положительных и количество отрицательных элементов массива.

Ответы на вопрос

Ответил Gleb1Kosyrev
0
//Dev-C++ 5.11 (C)

#include <stdio.h>

int main(void)
 {int arr[100],n,pos,neg;
 scanf("%d",&n);
 pos=0;
 neg=0;
 for(int i=0;i<n;i++)
  {scanf("%d",&arr[i]);
  if(arr[i]>0)
   pos++;
  if(arr[i]<0)
   neg++;}
 printf("%d %d",pos,neg);
 return 0;}
Новые вопросы