Информатика, вопрос задал Нвб , 8 лет назад

Дан массив А[10]. Найти МАХ элемент среди элементов, стоящих на чётных местах и найденным значением заменить все элементы массива А, кратные 3. Преобразованный массив вывести на экран. Напишите программу на языке паскаль, спасибо!

Ответы на вопрос

Ответил ManyGames
0
const
  CSize = 10;

var
  m: array[1..CSize] of integer;

begin
  randomize();
  var max := -(MaxInt);
  write('Исходный массив: ');
  for var i := 1 to CSize do
  begin
    m[i] := random(100) + 1;
    if (i mod 2 = 0) and (m[i] > max) then max := m[i];
    write(m[i], ' ')
  end;
  write(NewLine, 'Преобразованный массив: ');
  for var i := 1 to CSize do
  begin
    if m[i] mod 3 = 0 then m[i] := max;
    write(m[i], ' ')
  end
end.
Новые вопросы