Дан массив 10 целых чисел, в диапазоне от 1 до 30. Найти произведение элементов массива, кратных 5. Помогите написать программу! Паскаль
Ответы на вопрос
Ответ
begin
ReadArrInteger(10).Where( x -> x mod 5 = 0).Product().Print();
end.
PascalABC.NET
Ответ:
begin
var mas := ArrRandomInteger(10, 1, 30);
mas.Println;
var composition := 1;
for var i := 0 to mas.Length - 1 do
begin
if (mas[i] mod 5 = 0) then
begin
composition := composition * mas[i];
end;
end;
write(composition);
end.
Объяснение:
begin // Начало программы
var mas := ArrRandomInteger(10, 1, 30); // Объявление массива размером 10 + заполнение массива случайными значениями из диапазона [1, 30].
mas.Println; // Вывод массива
var composition := 1; // Переменная, хранящая произведение чисел, которые делятся на 5 без остатка
for var i := 0 to mas.Length - 1 do // Идём от нуля до размера массива - 1
begin // Начало цикла
if (mas[i] mod 5 = 0) then // Если значение массива с индексом i делится на 5 без остатка
begin // Начало условного оператора
composition := composition * mas[i]; // Умножаем произведение на значение массива
end; // Конец условного оператора
end; // Конец цикла
write(composition); // Выводим ответ
end. // Конец программы