Дан интервал (-12;22)
Написать программу, которая будет проверять принадлежит ли вводимое пользователем число данному интервалу. Если принадлежит, то в консоль должно вывести слово "Принадлежит". И в ином случаи "Не принадлежит". Надо написать код на языке c++, с условиями if, else
#include
using namespace std;
int main() {
int a;
cin >> a;
if (a > -13 || a < 23)
{
cout << "Принадлежит" << endl;
}
else {
cout << "Не принадлежит" << endl;
}
return 0;
}
#include
using namespace std;
int main() {
int a;
int min = -12;
int max = 22;
cin >> a;
if (min < a < max)
{
cout << "Принадлежит" << endl;
}
else {
cout << "Не принадлежит" << endl;
}
return 0;
}
вот мои 2 кода но они не рабочие, может помогут
Ответы на вопрос
Ответил TemaZpro
0
Ответ:
Первый код у вас больше всего похож на правду, вам в if нужно заменить символы || (ИЛИ) на && (И). Тогда должно заработать.
Еще вы забыли #include <iostream>, возможно у вас в коде он есть, но в вопросе вы написали только #include.
Новые вопросы
Українська мова,
1 год назад
Химия,
1 год назад
Химия,
1 год назад
Английский язык,
1 год назад
Алгебра,
6 лет назад