Дан двумерный массив целых чисел. Написать программу, которая:определяет номер последнего столбца, у которого нечетных элементов больше чем четных.(паскаль)
Ответы на вопрос
Ответил raf1O5
0
program raf105;
const
n = 5;
var
a: array[1..n,1..n] of integer;
i,j,num,n1,n2: integer;
begin
writeln('Вводите числа столбцов матрицы по очереди');
for i:=1 to n do
begin
writeln('Столбец ',i);
for j:=1 to n do
readln(a[i,j]);
end;
for i:=1 to n do
begin
n1:= 0;
n2:= 0;
for j:=1 to n do
begin
if (a[i,j] mod 2 <> 0) and (a[i,j] <> 0)
then n1:= n1+1;
end;
for j:=1 to n do
begin
if (a[i,j] mod 2 = 0) and (a[i,j] <> 0)
then n2:= n2+1;
end;
if n1 > n2
then num:= i;
end;
writeln('Вывод: ',num);
end.
PascalABC 3.4.2
Новые вопросы
Русский язык,
2 года назад
Другие предметы,
2 года назад
Химия,
7 лет назад
Математика,
7 лет назад
Биология,
9 лет назад