Дан целочисленный массив из 30-ти элементов.Написать программу,которая позволит найти среднее арифметическое положительных элементов массива .
Ответы на вопрос
Ответил TKOP
0
Паскаль:
var mas : array[1..30] of longint;
n,i : longint;
r : real;
begin
for i:=1 to 30 do read (mas[i]);
n:=30; r:=0;
for i:=1 to 30 do begin
if mas[i]<1 then begin mas[i]:=0; n:=n-1;
r:=r+mas[i];
end;
writeln(r/n);
end.
var mas : array[1..30] of longint;
n,i : longint;
r : real;
begin
for i:=1 to 30 do read (mas[i]);
n:=30; r:=0;
for i:=1 to 30 do begin
if mas[i]<1 then begin mas[i]:=0; n:=n-1;
r:=r+mas[i];
end;
writeln(r/n);
end.
Новые вопросы
Другие предметы,
2 года назад
Другие предметы,
2 года назад
Математика,
10 лет назад
Физика,
10 лет назад
Обществознание,
10 лет назад
Математика,
10 лет назад