дан целочисленный массив из 10 элементов все элементы которого целые числа в интервале от - 1000 до 1000. напишите программу которая находит количество элементов всех нечетных элементов массива которые делятся на 3
на языке Pascal желательно
Ответы на вопрос
Ответил Аноним
0
program E08;
uses crt;
var
X: array[-1000..1000] of integer;
S,i,k: integer;
begin
clrscr;
writeln('Введите массив X:');
for i:=1 to 10 do
begin
write('X[',i:2,'] ==> ');
readln(X[i])
end;
for i:=1 to 10 do
write(X[i],' ');
writeln;
K:=0;
for i:=1 to 10 do
begin
S:=X[i] mod 3;
if S = 0 then
K:=K+1
end;
writeln('Ответ: ',K)
end.
uses crt;
var
X: array[-1000..1000] of integer;
S,i,k: integer;
begin
clrscr;
writeln('Введите массив X:');
for i:=1 to 10 do
begin
write('X[',i:2,'] ==> ');
readln(X[i])
end;
for i:=1 to 10 do
write(X[i],' ');
writeln;
K:=0;
for i:=1 to 10 do
begin
S:=X[i] mod 3;
if S = 0 then
K:=K+1
end;
writeln('Ответ: ',K)
end.
Новые вопросы
Українська мова,
2 года назад
Алгебра,
9 лет назад
Геометрия,
9 лет назад
Физика,
10 лет назад
История,
10 лет назад