Дан целочисленный массив из 10 элементов. Напишите программу, которая находит количество пар элементов массива, в которых хотя бы одно число делится на 3, под парой подразумевается два идущих подряд массива. Например : 6;2 ;9;-3;6. Ответ :4. работа в паскаль, помогите плиз
Ответы на вопрос
Ответил 444ерор444
0
извиняюcь за то что долго
program z1;
var a:array[10];
k,i:integer;
begin
k:=0;
readln(a);
for i:= 1 to 9 do
if (a[i] mod 3 =0) or (a[i+1] mod 3 = 0) then k:=k+1;
end;
writeln(k);
end.
program z1;
var a:array[10];
k,i:integer;
begin
k:=0;
readln(a);
for i:= 1 to 9 do
if (a[i] mod 3 =0) or (a[i+1] mod 3 = 0) then k:=k+1;
end;
writeln(k);
end.
Ответил 444ерор444
0
вот, проверь в компиляторе если надо
Новые вопросы
Английский язык,
2 года назад
Математика,
9 лет назад