Дан целочисленный массив А[N]. Заменить все элементы массива, являющиеся простыми числами, на максимальное значение элементов массива. Написать программу на С++
Ответы на вопрос
Ответил lorex556
0
#include <bits/stdc++.h>
using namespace std;
int n,a,mx = -1e6,b[10101];
bool check(int x) {
for (int i = 2; i <= sqrt(x); i++)
if (x % i == 0) return 0;
return 1;
}
main () {
cin >>n;
for (int i = 1; i <= n; i++)
{
cin >>b[i];
mx = max(mx,b[i]);
}
for (int i = 1; i <= n; i++)
if (check(b[i])) b[i] = mx;
for (int i = 1; i <= n; i++)
cout <<b[i] <<" ";
}
Ответил mikimouse9
0
Что такое mx?
Новые вопросы
Русский язык,
2 года назад
Українська мова,
2 года назад
Алгебра,
7 лет назад
Математика,
7 лет назад
Геометрия,
9 лет назад