Информатика, вопрос задал yuliya13725 , 7 лет назад

Дам 70 баллов!!!

Надо написать программу на языке Паскаль, которая вычисляет сумму:

а) Первых n натуральных чисел;

б) Квадратов первых n натуральных чисел;

в) Всех чётных чисел в диапазоне от 1 до n;

г) Всех двузначных чисел.

Всё это надо написать одной программой через оператора repeat. НЕ С ИНТЕРНЕТА!!!

Ответы на вопрос

Ответил raf1O5
0

program raf105;

var

 n,i,a,b,c,d,sqrt: integer;

begin

 write('Введите n: ');

 readln(n);

 repeat

   i:= i+1;

   a:= a+i;

   sqrt:= i*i;

   b:= b+sqrt;

   if i mod 2 = 0

     then c:= c+i;

   if (i >= 10) and (i <= 99)

     then d:= d+i;

 until i = n;

 writeln('а) ',a);

 writeln('б) ',b);

 writeln('в) ',c);

 writeln('г) ',d);

end.

PascalABC 3.4.2

Ответил yuliya13725
0
Спасибо!
Новые вопросы