Информатика, вопрос задал xuki98 , 7 лет назад

ДАМ 50 БАЛЛОВ!!!!!! ЗАДАНИЕ С СИРИУС.КУРСОВ ПО ПИТОНУ.ПОМОГИТЕ!!!!! :



Факториал натурального числа n определяется как произведение всех натуральных чисел от 1 до n включительно и обозначается n!:


n!=1∗2∗3∗...∗n

Например, 3!=1∗2∗3=6.


Напишите программу, которая выводит на экран значение 20! (20 факториал).


MrSolution: это какой класс?

Ответы на вопрос

Ответил onetfriend
1

Ответ:

Объяснение:

Например так:

n=20

fact=1

for i in range(2,n+1):

 fact=fact*i

print("Факториал ",n," равен: ",fact)

Приложения:
Ответил MrSolution
0

Ответ:

(см. объяснение)

Объяснение:

Первый вариант:

r = 1

for i in range(2, 21):

   r *= i

print(r)

Второй вариант:

def fac(x):

   return x * fac(x - 1) if x > 1 else 1

print(fac(20))

Задание выполнено!

Новые вопросы