ДАМ 100 баллов пж
Дан целочисленный массив из 20 элементов. Числа по модулю не превышают 1000. Напишите программу, позволяющую найти и вывести наименьшее содержащееся в массиве положительное число, десятичная запись которого оканчивается цифрой 7. Гарантируется, что в массиве есть хотя бы один положительный элемент, десятичная запись которого оканчивается цифрой 7.
Ответы на вопрос
Ответил vimmortal2
0
Программа:
Pascal:
var
arr: array[1..20] of integer;
i, n: integer;
begin
// генерация массива из 20 чисел от -1000 до 1000
for i := 1 to 20 do arr[i] := random(-1000, 1000);
writeln(arr);
// определение минимальног очисла, которое заканчивается на 7
n := MAXINT;
for i := 1 to 20 do
if (arr[i] mod 10 = 7) and (arr[i] > 0) then
if arr[i] < n then n := arr[i];
writeln(n);
end.
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Физика,
7 лет назад
Английский язык,
7 лет назад
Физика,
8 лет назад