Информатика, вопрос задал Ivangai063 , 1 год назад

Дам 10 балов
Напишите программу calc, которая принимает 1 аргумент – число. Функция
должна вывести сумму цифр данного числа. Например: 456 -> 4 + 5 + 6 -> 15

Ответы на вопрос

Ответил artursolkh
1

Ответ: Вот программа на языке Python, которая выполняет описанный функционал:
----------------------------                                     ----------------------------------------------
def calc(num):

   sum = 0

   for digit in str(num):

       sum += int(digit)

   print(f"Сумма цифр числа {num}: {sum}")

-------------------------------                                     -------------------------------------------
calc(456) # выводит "Сумма цифр числа 456: 15"

---------------------------------------------------------------------------------------------------------
Функция calc принимает один аргумент num - число, сумму цифр которого нужно вычислить.

Далее создается переменная sum и присваивается начальное значение 0. Затем в цикле for мы проходимся по каждой цифре числа, преобразованного в строку с помощью функции str(num). Каждая цифра конвертируется обратно в целое число с помощью функции int(digit) и прибавляется к переменной sum.

Наконец, программа выводит сообщение о сумме цифр данного числа.

Объяснение: если помог отметь ответ как лучший

Новые вопросы