Информатика, вопрос задал dalerkuldashev , 1 год назад

Дается натуральное число N. Составьте программу, которая вычисляет сумму четных чисел от 1 до n и сумму нечетных чисел отдельно.C++

Ответы на вопрос

Ответил slonce70
1

#include <iostream>

using namespace std;

int main() {

 int n, even_sum = 0, odd_sum = 0;

 cout << "Введите натуральное число: ";

 cin >> n;

 // вычисление суммы четных чисел от 1 до n

 for(int i = 2; i <= n; i += 2) {

   even_sum += i;

 }

 // вычисление суммы нечетных чисел от 1 до n

 for(int i = 1; i <= n; i += 2) {

   odd_sum += i;

 }

 // вывод сумм четных и нечетных чисел

 cout << "Сумма четных чисел от 1 до " << n << ": " << even_sum << endl;

 cout << "Сумма нечетных чисел от 1 до " << n << ": " << odd_sum << endl;

 return 0;

}

Новые вопросы