Информатика, вопрос задал el0195178 , 1 год назад

Дается натуральное число N. Составьте программу, вычисляющую сумму квадратов целых чисел от 1 до N. C++

Ответы на вопрос

Ответил Ukraine124
1

Ответ:

#include <iostream>

int main() {

 int N;

 std::cout << "Введите число N: ";

 std::cin >> N;

 int sum = 0;

 for (int i = 1; i <= N; ++i) {

   sum += i * i;

 }

 std::cout << "Сумма квадратов от 1 до " << N << " равна " << sum << std::endl;

 return 0;

}

Объяснение:

Программа запрашивает у пользователя натуральное число N, затем использует цикл for для вычисления суммы квадратов целых чисел от 1 до N, сохраняя результат в переменную sum. Наконец, программа выводит результат на экран.

Новые вопросы