Cоставить алгоритм и написать программу.
Найдите дискриминант квадратного уравнения:y=5x^2+6x-7
Ответы на вопрос
Ответил vasxp
0
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
float a,b,c;
int d;
float x1, x2;
cout << "ax^2+bx+c=0" << endl;
cout << "Input a:" << endl;
cin >> a;
cout << "Input b:" << endl;
cin >> b;
cout << "Input c:" << endl;
cin >> c;
d= sqrt(b*b-4*a*c);
x1=((-1)*b+d)/(2*a);
x2=((-1)*b-d)/(2*a);
cout << "x1=" << x1 << endl;
cout << "x2=" << x2 << endl;
return 0;
}
Но есть корень из дискриминанта нормально не получится - оно не напишет тебе + √13 допустим, он посчитает корни приблизительно.
#include <math.h>
using namespace std;
int main()
{
float a,b,c;
int d;
float x1, x2;
cout << "ax^2+bx+c=0" << endl;
cout << "Input a:" << endl;
cin >> a;
cout << "Input b:" << endl;
cin >> b;
cout << "Input c:" << endl;
cin >> c;
d= sqrt(b*b-4*a*c);
x1=((-1)*b+d)/(2*a);
x2=((-1)*b-d)/(2*a);
cout << "x1=" << x1 << endl;
cout << "x2=" << x2 << endl;
return 0;
}
Но есть корень из дискриминанта нормально не получится - оно не напишет тебе + √13 допустим, он посчитает корни приблизительно.
Ответил vasxp
0
исправил
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Математика,
10 лет назад
Математика,
10 лет назад