Информатика, вопрос задал mariomariha1701 , 9 лет назад

цикл с предусловием(pascal abc net):
составить программу,вывести числа от -5 до 8 в одну строчку.

Ответы на вопрос

Ответил qwerty079
0
program five;
uses crt;
begin
writeln('-5 -4 -3 -2 -1 0 1 2 3 4 5 6 7 8');
end.
это не через цикл if, а просто выписаны числа.
Или тебе именно через цикл if надо?
Ответил qwerty079
0
program five;
uses crt;
var q,w,e,r,t,y,u,i,o,p,a,s,d,f:integer;
begin
writeln('Введите число -5:');readln(q);
if (q=-5) then writeln('Введите число -4:');
;readln(w);
if (w=-4) then writeln('Введите число -3:');
;readln(e);
if (e=-3) then writeln('Введите число -2:');
;readln(r);
if (r=-2) then writeln('Введите число -1:');
;readln(t);
if (t=-1) then writeln('Введите число 0:');
;readln(y);
if (y=0) then writeln('Введите число 1:');
Ответил qwerty079
0
;readln(u);
if (u=1) then writeln('Введите число 2:');
;readln(i);
if (i=2) then writeln('Введите число 3:');
;readln(o);
if (o=3) then writeln('Введите число 4:');
;readln(p);
if (p=4) then writeln('Введите число 5:');
;readln(a);
if (a=5) then writeln('Введите число 6:');
;readln(s);
if (s=6) then writeln('Введите число 7');
;readln(d);
if (d=7) then writeln('Введите число 8:')
;readln(f);
if (f=8)then writeln(q,' ',w,' ',e,' ',r,' ',t,' ',y,' ',u,' ',i,' ',o,' ',p,' ',a,' ',s,' ',d,' ',f);
end.
Ответил mariomariha1701
0
большое спасибо!
Ответил qwerty079
0
Вот так вот через if будет, просто введи то что просят и выведет в одну строку
Ответил mariomariha1701
0
хорошо, спасибо
Новые вопросы