Информатика, вопрос задал punpis080 , 7 лет назад

Цикл FOR
4. Напишите программу, которая в последовательности целых чисел определяет минимальное число, кратное 5 или 9. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000.


lozromanik: какой язык программирования?
punpis080: for
lozromanik: нет, типа на питоне или на с+?
punpis080: питон

Ответы на вопрос

Ответил korsa351
0

Array = []

el = int(input())

Array.append(el)

minn = 30001

while el != 0:

   el = int(input())

   Array.append(el)

Array.remove(0)

for i in range(len(Array)):

   if (Array[i] % 5 == 0 or Array[i] % 9 == 0) and Array[i] < minn:

       minn = Array[i]

print(minn)

Приложения:
Ответил teacher1011
0

arr = []

n = True

while n != 0:

   n = int(input())

   if n%5 == 0 and n%9 == 0 and n != 0:

       arr.append(n)

print(min(arr))

Новые вопросы