Информатика, вопрос задал Flapbooker , 7 лет назад

Цифровой корень. Код писать на Python3. Пожалуйста, если вы не знаете ответ или можете дать ответ только в обмен на другой, то не отвечайте.


Цифровой корень натурального числа получается следующим образом. Складываются все цифры данного числа. Процесс повторяется, пока в результате не будет получено однозначное число, которое и называется цифровым корнем числа.


Входные данные


На вход программе подается натуральное число n≤10^9.


Выходные данные


Выведите его цифровой корень.

Ответы на вопрос

Ответил KnowsUser1
0

Ответ:

def sum_number_digits(number):

   return sum([int(i) for i in list(str(number))])

number = input()

while len(str(number)) > 1:

   number = sum_number_digits(number)

print(number)

Приложения:
Новые вопросы