CИ
Написать программу, считывающую с клавиатуры
32-битное беззнаковое число n, числа a и b и
выводящую на экран число, равное исходному n, но с
установленным битом номер a и снятым битом номер b
Ответы на вопрос
Ответил Tracker
0
#include <iostream>
using namespace std;
int main() {
unsigned int n,a,b;
cin>>n>>a>>b;
n&=1<<a;
n&=(0xFFFFFFFF)-(1<<b);
cout<<n;
return 0;
}
Что-то в этом духе
using namespace std;
int main() {
unsigned int n,a,b;
cin>>n>>a>>b;
n&=1<<a;
n&=(0xFFFFFFFF)-(1<<b);
cout<<n;
return 0;
}
Что-то в этом духе
Новые вопросы
Математика,
2 года назад
История,
2 года назад
Геометрия,
9 лет назад
Алгебра,
9 лет назад
Биология,
10 лет назад