Информатика, вопрос задал SSA505 , 7 лет назад

Что-то подзабыл я pascal. Помогите написать программу в pascal, которая складывает последние 4 цифры любого задаваемого числа.

Ответы на вопрос

Ответил mylene59292
0
var a,s:integer;
begin
repeat readln(a) until a>9; // по условию число >9
s:=a mod 10; // забираем последнюю цифру
while a>9 do a:=a div 10; // вычеркиваем последнию цифру, пока а - двухзначное число
writeln(s+a mod 10) // теперь выводим сумму
end.
Ответил SSA505
0
и в каком же месте тут сумма последних 4 цифр числа?
Ответил SSA505
0
уже сам сообразил. ваша программа не корректна
Ответил mylene59292
0
это сумма первой и последе
Ответил SSA505
0
а вопрос бы последние 4
Ответил mylene59292
0
насчёт последних не сообразила
Новые вопросы