чему равна переменная s на выходе программы если на входе подали n=121 в ответе укажите число
var n,s,d:integer;
begin
readln(n);
s:=1; d:=2;
while n>=d do
begin
if (n mod d)=0 then s;=s+d;
d:=d+1;
end;
writeln(s);
end.
Ответы на вопрос
Ответил mewnet
0
как я понял, s - это сумма всех делителей числа 121(включая 1).
121=11*11
s=1+11+121=133
ответ:133
121=11*11
s=1+11+121=133
ответ:133
E97M:
спасибо, за ответ, но мне казалось число будет больше
Новые вопросы