Информатика, вопрос задал 1Отличница2 , 8 лет назад

C++. СРОЧНО составьте программу, где вводят 4-значное натуральное число и переставляет его первую и последнюю цифру. Например, 3456 должно получиться 6453

Ответы на вопрос

Ответил yaroslav2550
0
#include <iostream> 
using namespace std;
int main() {
 int n;  
 cin >> n;
 int a = n % 10, b = (n / 10) % 10, c = (n / 100) % 10, d = n / 1000;   
 cout << a * 1000 + c * 100 + b * 10 + d;
}
Новые вопросы