C++ срочно!
Дан массив из n элементов и число a. Необходимо найти сумму элементов, больших данного a.
Формат входных данных
С клавиатуры вводится натуральное число n (n≤100). На следующей строке через пробел вводятся n элементов массива. В последней строке содержится число a. Все числа по модулю не превосходят 100.
Формат выходных данных
В качестве ответа выведите единственное число — сумму элементов, удовлетворяющих условию.
Ответы на вопрос
Ответил ZufarAzizov
0
#include <iostream>
#include <vector>
#include <queue>
#include <set>
#include <cmath>
//#include <bits/stdc++.h>
using namespace std;
signed main() {
ios_base::sync_with_stdio(0);
cin.tie(0);
cout.tie(0);
int n;
cin >> n;
int a[n];
for(int i = 0; i < n; i++)
cin >> a[i];
int A;
cin >> A;
int cnt = 0;
for(auto i: a)
if(i > A)
cnt++;
cout << cnt;
}
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Геометрия,
7 лет назад
Физика,
7 лет назад
Математика,
9 лет назад