c++ помогите
Напишите программу, которая просит пользователя ввести строку s. Программа должна выводить каждую букву с номером повторения в строке s.
Приложения:

Ответы на вопрос
Ответил xedfr777
1
Ответ:
пожалуйста
Объяснение:
#include <bits/stdc++.h>
using namespace std;
int main() {
int cnt = 1;
string s;
cin >> s;
sort(s.begin(), s.end());
for (int i = 0; i < s.size() - 1; ++i) {
if (s[i + 1] == s[i]) {
cnt++;
} else {
cout << s[i] << " " << cnt << "\n";
cnt = 1;
}
}
cnt = 1;
for (int i = s.size() - 1; i > 0; i--) {
if (s[i] == s[i - 1]) {
cnt++;
} else {
cout << s[s.size() - 1] << " " << cnt << "\n";
break;
}
}
}
Новые вопросы
Қазақ тiлi,
2 года назад
Физика,
2 года назад
Математика,
2 года назад
Литература,
2 года назад
Геометрия,
8 лет назад
Физика,
8 лет назад