C++ ПОЛНАЯ ПРОГРАММА
НОК
Напишите программу, которая вычисляет наименьшее общее кратное двух чисел.
Входные данные
Входная строка содержит два натуральных числа, разделённые пробелом, — a и b. Гарантируется, что ответ не превосходит 2⋅10^9
Выходные данные
Программа должна вывести одно натуральное число: НОК заданных чисел.
Примеры
Ввод
14 21
Вывод
42
Ответы на вопрос
Ответил akmalsodikov04
1
Ответ:
Объяснение:
#include <iostream>
using namespace std;
long nod (int a, int b) {
return b == 0 ? a : nod (b, a % b);
}
int main() {
int t1, t2;
cin >> t1 >> t2;
cout << t1 * (t2 / nod (t1, t2));
return 0;
}
mnb5757:
Спасибо большое! Проверку прошла
Новые вопросы
Русский язык,
2 года назад
Немецкий язык,
2 года назад
Математика,
2 года назад
Математика,
2 года назад
Литература,
8 лет назад
История,
8 лет назад